mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
ca3757e1c2
The 'glibc-supported-locales.patch' was updated for glibc 2.29, breaking compatibility with 2.27. Add a 2.27-specific supported locales patch. * gnu/packages/patches/glibc-2.27-supported-locales.patch: New file. * gnu/packages/base.scm (glibc-2.27)[source](patches): Use 'glibc-2.27-supported-locales.patch' instead. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
33 lines
1 KiB
Diff
33 lines
1 KiB
Diff
This patch is taken from debian's glibc package (generate-supported.mk).
|
|
It install the localedata/SUPPORTED file of the glibc. This file lists
|
|
all the supported locales of the glibc.
|
|
|
|
diff --git a/localedata/Makefile.old b/localedata/Makefile
|
|
index 34877c0..a61d9b9 100644
|
|
--- a/localedata/Makefile.old
|
|
+++ b/localedata/Makefile
|
|
@@ -91,7 +91,8 @@ endif
|
|
# Files to install.
|
|
install-others := $(addprefix $(inst_i18ndir)/, \
|
|
$(addsuffix .gz, $(charmaps)) \
|
|
- $(locales))
|
|
+ $(locales)) \
|
|
+ $(inst_i18ndir)/SUPPORTED
|
|
|
|
tests: $(objdir)/iconvdata/gconv-modules
|
|
|
|
@@ -195,6 +196,14 @@ endif
|
|
|
|
include SUPPORTED
|
|
|
|
+$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
|
|
+ for locale in $(SUPPORTED-LOCALES); do \
|
|
+ [ $$locale = true ] && continue; \
|
|
+ echo $$locale | sed 's,/, ,' >> LOCALES; \
|
|
+ done
|
|
+ $(make-target-directory)
|
|
+ $(INSTALL_DATA) LOCALES $@
|
|
+
|
|
INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
|
|
|
|
# Sometimes the whole collection of locale files should be installed.
|