mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-26 12:39:36 -05:00
6312c68f70
* gnu/packages/julia.scm (julia)[origin]<patches>: New patch. * gnu/packages/patches/julia-allow-parallel-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
30 lines
893 B
Diff
30 lines
893 B
Diff
diff --git a/test/runtests.jl b/test/runtests.jl
|
|
index 2f9cd058bb..150395e78c 100644
|
|
--- a/test/runtests.jl
|
|
+++ b/test/runtests.jl
|
|
@@ -4,7 +4,7 @@ using Test
|
|
using Distributed
|
|
using Dates
|
|
import REPL
|
|
-using Printf: @sprintf
|
|
+using Printf: @sprintf, @printf
|
|
using Base: Experimental
|
|
|
|
include("choosetests.jl")
|
|
@@ -83,11 +83,15 @@ prepend!(tests, linalg_tests)
|
|
import LinearAlgebra
|
|
cd(@__DIR__) do
|
|
n = 1
|
|
- if net_on
|
|
+ # Allow parallel tests with isolated environment
|
|
+ # https://github.com/JuliaLang/julia/issues/43205
|
|
+ # https://github.com/JuliaLang/julia/pull/43211
|
|
+ if net_on || haskey(ENV, "JULIA_CPU_THREADS")
|
|
n = min(Sys.CPU_THREADS, length(tests))
|
|
n > 1 && addprocs_with_testenv(n)
|
|
LinearAlgebra.BLAS.set_num_threads(1)
|
|
end
|
|
+ @printf("Number of threads: %i\n", n)
|
|
skipped = 0
|
|
|
|
@everywhere include("testdefs.jl")
|