mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 19:35:25 -05:00
2e28b450d5
* gnu/packages/emacs-xyz.scm (emacs-telega-server): Update to 0.7.15-1.b4a5e20. * gnu/packages/patches/emacs-telega-path-placeholder.patch: Match patch with newer source code. * gnu/packages/patches/emacs-telega-test-env.patch: Match patch with newer source code. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
From bf95de21faa623e48bca00d6a2c9b33ab2c5d812 Mon Sep 17 00:00:00 2001
|
|
From: Andrew Tropin <andrew@trop.in>
|
|
Date: Wed, 8 Dec 2021 11:01:31 +0300
|
|
Subject: [PATCH] Use absolute path for telega-server-command.
|
|
|
|
---
|
|
telega-customize.el | 2 +-
|
|
telega-util.el | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/telega-customize.el b/telega-customize.el
|
|
index 0af343f..cc2938c 100644
|
|
--- a/telega-customize.el
|
|
+++ b/telega-customize.el
|
|
@@ -591,7 +591,7 @@ In range [1..3]. Use 1."
|
|
:prefix "telega-server-"
|
|
:group 'telega)
|
|
|
|
-(defcustom telega-server-command "telega-server"
|
|
+(defcustom telega-server-command "@TELEGA_SERVER_BIN@"
|
|
"Command to run as telega server.
|
|
It should be absolute path or binary file searchable in `exec-path'."
|
|
:type 'string
|
|
diff --git a/telega-util.el b/telega-util.el
|
|
index 6340c27..01e3cb7 100644
|
|
--- a/telega-util.el
|
|
+++ b/telega-util.el
|
|
@@ -587,7 +587,7 @@ N can't be 0."
|
|
|
|
(defun telega-etc-file (filename)
|
|
"Return absolute path to FILENAME from etc/ directory in telega."
|
|
- (expand-file-name (concat "etc/" filename) telega--lib-directory))
|
|
+ (concat "@TELEGA_SHARE@" "/" filename))
|
|
|
|
(defun telega-link-props (link-type link-to &optional face)
|
|
"Generate props for link button openable with `telega-link--button-action'."
|
|
--
|
|
2.34.0
|
|
|