mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-20 05:37:34 -05:00
2c0013916e
* gnu/packages/gl.scm (mesa): Update to 21.1.6. * gnu/packages/patches/mesa-skip-tests.patch: Remove cache_test.c as it is no longer needed (test passes). Signed-off-by: Ludovic Courtès <ludo@gnu.org>
29 lines
861 B
Diff
29 lines
861 B
Diff
This test fails on i686-linux. I couldn't come up with a regex that
|
|
could be used to disable it just on i686-linux, so we disable it
|
|
completely with this patch:
|
|
|
|
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
|
|
|
|
diff --git a/src/util/meson.build b/src/util/meson.build
|
|
index 0893f64..909b3e0 100644
|
|
--- a/src/util/meson.build
|
|
+++ b/src/util/meson.build
|
|
@@ -289,18 +289,6 @@ if with_tests
|
|
suite : ['util'],
|
|
)
|
|
|
|
- test(
|
|
- 'u_debug_stack',
|
|
- executable(
|
|
- 'u_debug_stack_test',
|
|
- files('u_debug_stack_test.cpp'),
|
|
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
|
|
- dependencies : [idep_mesautil, idep_gtest],
|
|
- c_args : [c_msvc_compat_args],
|
|
- ),
|
|
- suite : ['util'],
|
|
- )
|
|
-
|
|
process_test_exe = executable(
|
|
'process_test',
|
|
files('process_test.c'),
|