mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
f7e8be2318
* gnu/packages/patches/texinfo-headings-single.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/texinfo.scm (texinfo)[source](patches): New field. * gnu/packages/commencement.scm (texinfo-boot0)[source]: Use BOOTSTRAP-ORIGIN.
21 lines
864 B
Diff
21 lines
864 B
Diff
Fix a regression in 6.8 where the 'single' headings option was not recognized.
|
|
|
|
Taken from upstream:
|
|
|
|
https://git.savannah.gnu.org/cgit/texinfo.git/commit/?id=13a8894fe2faa45b04033d7122a8fe7939ce6aa2
|
|
|
|
diff --git a/tp/Texinfo/XS/parsetexi/end_line.c b/tp/Texinfo/XS/parsetexi/end_line.c
|
|
index 4556780052..3fc2065616 100644
|
|
--- a/tp/Texinfo/XS/parsetexi/end_line.c
|
|
+++ b/tp/Texinfo/XS/parsetexi/end_line.c
|
|
@@ -778,8 +778,8 @@ kdbinputstyle_invalid:
|
|
case CM_headings:
|
|
{
|
|
if (!strcmp (line, "off") || !strcmp (line, "on")
|
|
- || !strcmp (line, "double") || !strcmp (line, "singleafter")
|
|
- || !strcmp (line, "doubleafter"))
|
|
+ || !strcmp (line, "single") || !strcmp (line, "double")
|
|
+ || !strcmp (line, "singleafter") || !strcmp (line, "doubleafter"))
|
|
{
|
|
ADD_ARG(line);
|
|
}
|