summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2025-03-09 23:44:45 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2025-03-09 23:44:45 -0400
commit365a13de3e19c66f6bb2ffb806e8086a068ffc25 (patch)
tree5a42e6a12b06124bc9b34c77f5b85ea988759f38
parentb64aeaac7a6316181e8cec7eb7530c08fb9eca41 (diff)
changed hyprland build, added mouse fx, firefox changes
-rw-r--r--home-config/home-configuration.scm14
-rw-r--r--home-config/hypr/hyprland.conf41
-rwxr-xr-xhome-config/hypr/scripts/autostart.sh (renamed from home-config/hypr/autostart.sh)0
-rwxr-xr-xhome-config/hypr/scripts/perf_mode.sh (renamed from home-config/hypr/perf_mode.sh)0
-rw-r--r--home-config/nix-home-manager/firefox-nightly/default.nix2
-rw-r--r--home-config/nix-home-manager/flake.lock48
-rw-r--r--home-config/nix-home-manager/flake.nix13
-rw-r--r--home-config/nix-home-manager/home.nix17
8 files changed, 125 insertions, 10 deletions
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm
index 8da1a78..27fe820 100644
--- a/home-config/home-configuration.scm
+++ b/home-config/home-configuration.scm
@@ -109,6 +109,10 @@
109 "texlive-setspace" 109 "texlive-setspace"
110 "texlive-booktabs" 110 "texlive-booktabs"
111 "texlive-mdwtools" 111 "texlive-mdwtools"
112 "texlive-caption"
113 "texlive-diagbox"
114 "texlive-pict2e"
115 "texlive-ulem"
112 "zathura" 116 "zathura"
113 "zathura-pdf-mupdf" 117 "zathura-pdf-mupdf"
114 "go" 118 "go"
@@ -156,7 +160,15 @@
156 ("nvim/after/ftplugin/markdown/custom.vim" ,(local-file "nvim/config/after/ftplugin/markdown/custom.vim")) 160 ("nvim/after/ftplugin/markdown/custom.vim" ,(local-file "nvim/config/after/ftplugin/markdown/custom.vim"))
157 ("nvim/after/ftplugin/mail/custom.vim" ,(local-file "nvim/config/after/ftplugin/mail/custom.vim")) 161 ("nvim/after/ftplugin/mail/custom.vim" ,(local-file "nvim/config/after/ftplugin/mail/custom.vim"))
158 ("sway" ,(local-file "sway" #:recursive? #t)) 162 ("sway" ,(local-file "sway" #:recursive? #t))
159 ("hypr" ,(local-file "hypr" #:recursive? #t)) 163 ;("hypr" ,(local-file "hypr" #:recursive? #t))
164 ("hypr/monitors.conf", (local-file "hypr/monitors.conf"))
165 ("hypr/family_guy.mp4", (local-file "hypr/family_guy.mp4"))
166 ("hypr/hyprlock.conf", (local-file "hypr/hyprlock.conf"))
167 ("hypr/hypridle.conf", (local-file "hypr/hypridle.conf"))
168 ("hypr/kanshi.conf", (local-file "hypr/kanshi.conf"))
169 ("hypr/subwaysurfer.webm", (local-file "hypr/subwaysurfer.webm"))
170 ("hypr/Wallpapers", (local-file "hypr/Wallpapers" #:recursive? #t))
171 ("hypr/scripts", (local-file "hypr/scripts" #:recursive? #t))
160 ("wpaperd" ,(local-file "wpaperd" #:recursive? #t)) 172 ("wpaperd" ,(local-file "wpaperd" #:recursive? #t))
161 ("mpv" ,(local-file "mpv" #:recursive? #t)) 173 ("mpv" ,(local-file "mpv" #:recursive? #t))
162 ("foot" ,(local-file "foot" #:recursive? #t)) 174 ("foot" ,(local-file "foot" #:recursive? #t))
diff --git a/home-config/hypr/hyprland.conf b/home-config/hypr/hyprland.conf
index 15e12fa..79917a1 100644
--- a/home-config/hypr/hyprland.conf
+++ b/home-config/hypr/hyprland.conf
@@ -213,12 +213,12 @@ bind = $mainMod, L, exec, hyprlock
213bind = $mainMod SHIFT, L, exec, loginctl suspend 213bind = $mainMod SHIFT, L, exec, loginctl suspend
214 214
215# Keybind to toggle "performance mode" (toggles GPU intensive things) 215# Keybind to toggle "performance mode" (toggles GPU intensive things)
216bind = $mainMod, F1, exec, ~/.config/hypr/perf_mode.sh 216bind = $mainMod, F1, exec, ~/.config/hypr/scripts/perf_mode.sh
217 217
218# Keybind for screenshot 218# Keybind for screenshot
219bind = $mainMod SHIFT, S, exec, grimblast copy area 219bind = $mainMod SHIFT, S, exec, grimblast copy area
220bind = $mainMod SHIFT, Print, exec, grimblast edit area 220bind = $mainMod SHIFT, Print, exec, grimblast edit area
221bind = $mainMod, S, exec, grimblast save area - | imv - 221bind = $mainMod, S, exec, imv <(grimblast save area -)
222 222
223# Notifications keybinds 223# Notifications keybinds
224bind = $mainMod, N, exec, makoctl dismiss 224bind = $mainMod, N, exec, makoctl dismiss
@@ -270,9 +270,44 @@ windowrulev2 = size 595 336,class:^(mpv)$, title:^(family_guy.mp4 - mpv)$
270windowrulev2 = move 67% 5% ,class:^(mpv)$, title:^(family_guy.mp4 - mpv)$ 270windowrulev2 = move 67% 5% ,class:^(mpv)$, title:^(family_guy.mp4 - mpv)$
271windowrulev2 = pin,class:^(mpv)$, title:^(family_guy.mp4 - mpv)$ 271windowrulev2 = pin,class:^(mpv)$, title:^(family_guy.mp4 - mpv)$
272 272
273exec-once = ~/.config/hypr/autostart.sh 273exec-once = ~/.config/hypr/scripts/autostart.sh
274 274
275misc { 275misc {
276 disable_hyprland_logo = true 276 disable_hyprland_logo = true
277 force_default_wallpaper = 0 277 force_default_wallpaper = 0
278} 278}
279
280# Cursors!
281plugin:dynamic-cursors {
282 enabled = true
283 mode = tilt
284 threshold = 2
285 tilt {
286 limit = 5000
287 function = negative_quadratic
288 }
289
290 shake {
291 enabled = true
292 nearest = true
293 threshold = 6.0
294 base = 4.0
295 speed = 4.0
296 influence = 0.0
297
298 limit = 0.0
299
300 timeout = 2000
301
302 effects = true
303
304 ipc = false
305 }
306
307 hyprcursor {
308 nearest = true
309 enabled = true
310 resolution = -1
311 fallback = clientside
312 }
313}
diff --git a/home-config/hypr/autostart.sh b/home-config/hypr/scripts/autostart.sh
index b531c5b..b531c5b 100755
--- a/home-config/hypr/autostart.sh
+++ b/home-config/hypr/scripts/autostart.sh
diff --git a/home-config/hypr/perf_mode.sh b/home-config/hypr/scripts/perf_mode.sh
index c195688..c195688 100755
--- a/home-config/hypr/perf_mode.sh
+++ b/home-config/hypr/scripts/perf_mode.sh
diff --git a/home-config/nix-home-manager/firefox-nightly/default.nix b/home-config/nix-home-manager/firefox-nightly/default.nix
index f6adc4a..cffaa1d 100644
--- a/home-config/nix-home-manager/firefox-nightly/default.nix
+++ b/home-config/nix-home-manager/firefox-nightly/default.nix
@@ -11,7 +11,7 @@ in
11{ 11{
12 programs.firefox = { 12 programs.firefox = {
13 enable = true; 13 enable = true;
14 package = wrapped-ff-nightly; 14 #package = wrapped-ff-nightly;
15 15
16 profiles.${config.home.username} = { 16 profiles.${config.home.username} = {
17 name = "${config.home.username}"; 17 name = "${config.home.username}";
diff --git a/home-config/nix-home-manager/flake.lock b/home-config/nix-home-manager/flake.lock
index 9316edc..a0c7e15 100644
--- a/home-config/nix-home-manager/flake.lock
+++ b/home-config/nix-home-manager/flake.lock
@@ -49,6 +49,27 @@
49 "type": "github" 49 "type": "github"
50 } 50 }
51 }, 51 },
52 "clipboard-sync": {
53 "inputs": {
54 "nixpkgs": [
55 "nixpkgs"
56 ]
57 },
58 "locked": {
59 "lastModified": 1731355357,
60 "narHash": "sha256-kTXsO+hskCfX36+Ez1fHu9SO54uUY2lofkrbMKE3Vrk=",
61 "owner": "dnut",
62 "repo": "clipboard-sync",
63 "rev": "943e49e0a9a16b54bbab3704e99b6cf6ad4ea19f",
64 "type": "github"
65 },
66 "original": {
67 "owner": "dnut",
68 "repo": "clipboard-sync",
69 "rev": "943e49e0a9a16b54bbab3704e99b6cf6ad4ea19f",
70 "type": "github"
71 }
72 },
52 "flake-compat": { 73 "flake-compat": {
53 "flake": false, 74 "flake": false,
54 "locked": { 75 "locked": {
@@ -156,6 +177,31 @@
156 "type": "github" 177 "type": "github"
157 } 178 }
158 }, 179 },
180 "hypr-dynamic-cursors": {
181 "inputs": {
182 "hyprland": [
183 "hyprland"
184 ],
185 "nixpkgs": [
186 "hyprland",
187 "nixpkgs"
188 ]
189 },
190 "locked": {
191 "lastModified": 1738522286,
192 "narHash": "sha256-Fg4+6Yko8V9b19/62jfKH0IWTiiRDMso1P1TnjAcs/8=",
193 "owner": "VirtCode",
194 "repo": "hypr-dynamic-cursors",
195 "rev": "fd6214629937949ecd8a39f4b5ebbce2afac0dd5",
196 "type": "github"
197 },
198 "original": {
199 "owner": "VirtCode",
200 "repo": "hypr-dynamic-cursors",
201 "rev": "fd6214629937949ecd8a39f4b5ebbce2afac0dd5",
202 "type": "github"
203 }
204 },
159 "hyprcursor": { 205 "hyprcursor": {
160 "inputs": { 206 "inputs": {
161 "hyprlang": [ 207 "hyprlang": [
@@ -725,7 +771,9 @@
725 }, 771 },
726 "root": { 772 "root": {
727 "inputs": { 773 "inputs": {
774 "clipboard-sync": "clipboard-sync",
728 "home-manager": "home-manager", 775 "home-manager": "home-manager",
776 "hypr-dynamic-cursors": "hypr-dynamic-cursors",
729 "hyprland": "hyprland", 777 "hyprland": "hyprland",
730 "hyprlock": "hyprlock", 778 "hyprlock": "hyprlock",
731 "hyprpicker-git": "hyprpicker-git", 779 "hyprpicker-git": "hyprpicker-git",
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
index b680ab9..ba3d01a 100644
--- a/home-config/nix-home-manager/flake.nix
+++ b/home-config/nix-home-manager/flake.nix
@@ -33,9 +33,18 @@
33 url = "github:nix-community/flake-firefox-nightly/3391372604cd3def19e6df88a51f1882aabcd59f"; 33 url = "github:nix-community/flake-firefox-nightly/3391372604cd3def19e6df88a51f1882aabcd59f";
34 inputs.nixpkgs.follows = "nixpkgs"; 34 inputs.nixpkgs.follows = "nixpkgs";
35 }; 35 };
36 clipboard-sync = {
37 url = "github:dnut/clipboard-sync/943e49e0a9a16b54bbab3704e99b6cf6ad4ea19f";
38 inputs.nixpkgs.follows = "nixpkgs";
39 };
40 hypr-dynamic-cursors = {
41 url = "github:VirtCode/hypr-dynamic-cursors/fd6214629937949ecd8a39f4b5ebbce2afac0dd5";
42 inputs.hyprland.follows = "hyprland";
43 inputs.nixpkgs.follows = "hyprland/nixpkgs";
44 };
36 }; 45 };
37 46
38 outputs = { nixpkgs, home-manager, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, ... }@inputs: 47 outputs = { nixpkgs, home-manager, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, clipboard-sync, hypr-dynamic-cursors, ... }@inputs:
39 let 48 let
40 system = "x86_64-linux"; 49 system = "x86_64-linux";
41 pkgs = nixpkgs.legacyPackages.${system}; 50 pkgs = nixpkgs.legacyPackages.${system};
@@ -59,6 +68,8 @@
59 inherit hyprlock; 68 inherit hyprlock;
60 inherit hyprpicker-git; 69 inherit hyprpicker-git;
61 inherit mozff; 70 inherit mozff;
71 inherit clipboard-sync;
72 inherit hypr-dynamic-cursors;
62 }; 73 };
63 } 74 }
64 ]; 75 ];
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index 4c72beb..d2e0034 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -1,4 +1,4 @@
1{ config, pkgs, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, ... }: 1{ config, pkgs, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, clipboard-sync, hypr-dynamic-cursors, ... }:
2 2
3{ 3{
4 imports = [ 4 imports = [
@@ -32,7 +32,15 @@
32 serif = [ "DejaVu Serif" ]; 32 serif = [ "DejaVu Serif" ];
33 }; 33 };
34 34
35 # wayland.windowManager.hyprland.enable = true; 35 wayland.windowManager.hyprland = {
36 enable = true;
37 package = hyprland.packages.${pkgs.system}.hyprland;
38 portalPackage = hyprland.packages.${pkgs.system}.xdg-desktop-portal-hyprland;
39 extraConfig = ''
40 ${builtins.readFile ../hypr/hyprland.conf}
41 '';
42 plugins = [ hypr-dynamic-cursors.packages.${pkgs.system}.hypr-dynamic-cursors ];
43 };
36 44
37 programs.starship = { 45 programs.starship = {
38 enable = true; 46 enable = true;
@@ -98,11 +106,12 @@
98 '') 106 '')
99 107
100 # Flakes specific things defined in flake.nix 108 # Flakes specific things defined in flake.nix
101 hyprland.packages.${pkgs.system}.default 109 #hyprland.packages.${pkgs.system}.default
102 hyprland.packages.${pkgs.system}.xdg-desktop-portal-hyprland 110 #hyprland.packages.${pkgs.system}.xdg-desktop-portal-hyprland
103 nixgl.packages.${pkgs.system}.nixGLIntel 111 nixgl.packages.${pkgs.system}.nixGLIntel
104 wpaperd.packages.${pkgs.system}.wpaperd 112 wpaperd.packages.${pkgs.system}.wpaperd
105 hyprpicker-git.packages.${pkgs.system}.hyprpicker 113 hyprpicker-git.packages.${pkgs.system}.hyprpicker
114 clipboard-sync.packages.${pkgs.system}.default
106 115
107 # Fonts! 116 # Fonts!
108 noto-fonts 117 noto-fonts