summaryrefslogtreecommitdiff
path: root/home-config/hypr/scripts/autostart.sh
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/hypr/scripts/autostart.sh')
-rwxr-xr-xhome-config/hypr/scripts/autostart.sh36
1 files changed, 36 insertions, 0 deletions
diff --git a/home-config/hypr/scripts/autostart.sh b/home-config/hypr/scripts/autostart.sh
new file mode 100755
index 0000000..b531c5b
--- /dev/null
+++ b/home-config/hypr/scripts/autostart.sh
@@ -0,0 +1,36 @@
1#!/usr/bin/env bash
2
3waybar &
4
5mako &
6
7#swaybg -i ~/.config/hypr/Wallpapers/above-clouds.jpg &
8
9nice -n13 swww init &
10
11#~/.config/hypr/wallpaper-daemon.sh &
12wpaperd -d &
13
14#swayidle -w timeout 300 'swaylock --screenshots --clock --indicator --grace 3 --fade-in 1 --effect-blur 7x5 --effect-greyscale' timeout 600 'hyprctl dispatch dpms off' resume 'hyprctl dispatch dpms on' before-sleep 'swaylock -f -c 000000' &
15
16hypridle &
17
18syncthing serve --no-browser &
19
20# Kill any orphans of this
21killall wl-clip-persist
22wl-clip-persist -c regular --reconnect-tries 5 &
23
24kanshi -c ~/.config/hypr/kanshi.conf &
25
26# Start the portals
27
28sleep 0.5
29killall -e xdg-desktop-portal-hyprland
30killall xdg-desktop-portal-gtk
31killall xdk-desktop-portal
32
33~/.nix-profile/libexec/xdg-desktop-portal-hyprland &
34~/.nix-profile/libexec/xdg-desktop-portal-gtk &
35sleep 2
36XDG_DESKTOP_PORTAL_DIR="/home/ryan/.nix-profile/share/xdg-desktop-portal/portals" ~/.nix-profile/libexec/xdg-desktop-portal &