diff options
Diffstat (limited to 'home-config/hypr/scripts')
-rwxr-xr-x | home-config/hypr/scripts/autostart.sh | 36 | ||||
-rwxr-xr-x | home-config/hypr/scripts/perf_mode.sh | 14 |
2 files changed, 50 insertions, 0 deletions
diff --git a/home-config/hypr/scripts/autostart.sh b/home-config/hypr/scripts/autostart.sh new file mode 100755 index 0000000..b531c5b --- /dev/null +++ b/home-config/hypr/scripts/autostart.sh | |||
@@ -0,0 +1,36 @@ | |||
1 | #!/usr/bin/env bash | ||
2 | |||
3 | waybar & | ||
4 | |||
5 | mako & | ||
6 | |||
7 | #swaybg -i ~/.config/hypr/Wallpapers/above-clouds.jpg & | ||
8 | |||
9 | nice -n13 swww init & | ||
10 | |||
11 | #~/.config/hypr/wallpaper-daemon.sh & | ||
12 | wpaperd -d & | ||
13 | |||
14 | #swayidle -w timeout 300 'swaylock --screenshots --clock --indicator --grace 3 --fade-in 1 --effect-blur 7x5 --effect-greyscale' timeout 600 'hyprctl dispatch dpms off' resume 'hyprctl dispatch dpms on' before-sleep 'swaylock -f -c 000000' & | ||
15 | |||
16 | hypridle & | ||
17 | |||
18 | syncthing serve --no-browser & | ||
19 | |||
20 | # Kill any orphans of this | ||
21 | killall wl-clip-persist | ||
22 | wl-clip-persist -c regular --reconnect-tries 5 & | ||
23 | |||
24 | kanshi -c ~/.config/hypr/kanshi.conf & | ||
25 | |||
26 | # Start the portals | ||
27 | |||
28 | sleep 0.5 | ||
29 | killall -e xdg-desktop-portal-hyprland | ||
30 | killall xdg-desktop-portal-gtk | ||
31 | killall xdk-desktop-portal | ||
32 | |||
33 | ~/.nix-profile/libexec/xdg-desktop-portal-hyprland & | ||
34 | ~/.nix-profile/libexec/xdg-desktop-portal-gtk & | ||
35 | sleep 2 | ||
36 | XDG_DESKTOP_PORTAL_DIR="/home/ryan/.nix-profile/share/xdg-desktop-portal/portals" ~/.nix-profile/libexec/xdg-desktop-portal & | ||
diff --git a/home-config/hypr/scripts/perf_mode.sh b/home-config/hypr/scripts/perf_mode.sh new file mode 100755 index 0000000..c195688 --- /dev/null +++ b/home-config/hypr/scripts/perf_mode.sh | |||
@@ -0,0 +1,14 @@ | |||
1 | #!/usr/bin/env bash | ||
2 | HYPRGAMEMODE=$(hyprctl getoption animations:enabled | awk 'NR==1{print $2}') | ||
3 | if [ "$HYPRGAMEMODE" = 1 ] ; then | ||
4 | hyprctl --batch "\ | ||
5 | keyword animations:enabled 0;\ | ||
6 | keyword decoration:drop_shadow 0;\ | ||
7 | keyword decoration:blur:enabled 0;\ | ||
8 | keyword general:gaps_in 0;\ | ||
9 | keyword general:gaps_out 0;\ | ||
10 | keyword general:border_size 1;\ | ||
11 | keyword decoration:rounding 0" | ||
12 | exit | ||
13 | fi | ||
14 | hyprctl reload | ||