summaryrefslogtreecommitdiff
path: root/home-config/hypr/scripts
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2025-03-09 23:44:45 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2025-03-09 23:44:45 -0400
commit365a13de3e19c66f6bb2ffb806e8086a068ffc25 (patch)
tree5a42e6a12b06124bc9b34c77f5b85ea988759f38 /home-config/hypr/scripts
parentb64aeaac7a6316181e8cec7eb7530c08fb9eca41 (diff)
changed hyprland build, added mouse fx, firefox changes
Diffstat (limited to 'home-config/hypr/scripts')
-rwxr-xr-xhome-config/hypr/scripts/autostart.sh36
-rwxr-xr-xhome-config/hypr/scripts/perf_mode.sh14
2 files changed, 50 insertions, 0 deletions
diff --git a/home-config/hypr/scripts/autostart.sh b/home-config/hypr/scripts/autostart.sh
new file mode 100755
index 0000000..b531c5b
--- /dev/null
+++ b/home-config/hypr/scripts/autostart.sh
@@ -0,0 +1,36 @@
1#!/usr/bin/env bash
2
3waybar &
4
5mako &
6
7#swaybg -i ~/.config/hypr/Wallpapers/above-clouds.jpg &
8
9nice -n13 swww init &
10
11#~/.config/hypr/wallpaper-daemon.sh &
12wpaperd -d &
13
14#swayidle -w timeout 300 'swaylock --screenshots --clock --indicator --grace 3 --fade-in 1 --effect-blur 7x5 --effect-greyscale' timeout 600 'hyprctl dispatch dpms off' resume 'hyprctl dispatch dpms on' before-sleep 'swaylock -f -c 000000' &
15
16hypridle &
17
18syncthing serve --no-browser &
19
20# Kill any orphans of this
21killall wl-clip-persist
22wl-clip-persist -c regular --reconnect-tries 5 &
23
24kanshi -c ~/.config/hypr/kanshi.conf &
25
26# Start the portals
27
28sleep 0.5
29killall -e xdg-desktop-portal-hyprland
30killall xdg-desktop-portal-gtk
31killall xdk-desktop-portal
32
33~/.nix-profile/libexec/xdg-desktop-portal-hyprland &
34~/.nix-profile/libexec/xdg-desktop-portal-gtk &
35sleep 2
36XDG_DESKTOP_PORTAL_DIR="/home/ryan/.nix-profile/share/xdg-desktop-portal/portals" ~/.nix-profile/libexec/xdg-desktop-portal &
diff --git a/home-config/hypr/scripts/perf_mode.sh b/home-config/hypr/scripts/perf_mode.sh
new file mode 100755
index 0000000..c195688
--- /dev/null
+++ b/home-config/hypr/scripts/perf_mode.sh
@@ -0,0 +1,14 @@
1#!/usr/bin/env bash
2HYPRGAMEMODE=$(hyprctl getoption animations:enabled | awk 'NR==1{print $2}')
3if [ "$HYPRGAMEMODE" = 1 ] ; then
4 hyprctl --batch "\
5 keyword animations:enabled 0;\
6 keyword decoration:drop_shadow 0;\
7 keyword decoration:blur:enabled 0;\
8 keyword general:gaps_in 0;\
9 keyword general:gaps_out 0;\
10 keyword general:border_size 1;\
11 keyword decoration:rounding 0"
12 exit
13fi
14hyprctl reload