diff options
author | Ryan Schanzenbacher <ryan@rschanz.org> | 2024-10-28 23:57:03 -0400 |
---|---|---|
committer | Ryan Schanzenbacher <ryan@rschanz.org> | 2024-10-28 23:57:03 -0400 |
commit | bdb08351ce1afc15264658bcbb6ec03144874759 (patch) | |
tree | 72e9eff827b961c475ae9ecf524ca17ecd4956b9 | |
parent | c23b60f866a687aa6ae3618265f47ae63c9c5b64 (diff) |
Changed firefox to nightly bin overlay. Flake will be impure for the
time being while I try sidebar tabs... :/
-rw-r--r-- | home-config/nix-home-manager/flake.lock | 244 | ||||
-rw-r--r-- | home-config/nix-home-manager/flake.nix | 11 | ||||
-rw-r--r-- | home-config/nix-home-manager/home.nix | 2 |
3 files changed, 73 insertions, 184 deletions
diff --git a/home-config/nix-home-manager/flake.lock b/home-config/nix-home-manager/flake.lock index d350b50..b6d3733 100644 --- a/home-config/nix-home-manager/flake.lock +++ b/home-config/nix-home-manager/flake.lock | |||
@@ -2,10 +2,22 @@ | |||
2 | "nodes": { | 2 | "nodes": { |
3 | "aquamarine": { | 3 | "aquamarine": { |
4 | "inputs": { | 4 | "inputs": { |
5 | "hyprutils": "hyprutils", | 5 | "hyprutils": [ |
6 | "hyprwayland-scanner": "hyprwayland-scanner", | 6 | "hyprland", |
7 | "nixpkgs": "nixpkgs", | 7 | "hyprutils" |
8 | "systems": "systems" | 8 | ], |
9 | "hyprwayland-scanner": [ | ||
10 | "hyprland", | ||
11 | "hyprwayland-scanner" | ||
12 | ], | ||
13 | "nixpkgs": [ | ||
14 | "hyprland", | ||
15 | "nixpkgs" | ||
16 | ], | ||
17 | "systems": [ | ||
18 | "hyprland", | ||
19 | "systems" | ||
20 | ] | ||
9 | }, | 21 | }, |
10 | "locked": { | 22 | "locked": { |
11 | "lastModified": 1729527199, | 23 | "lastModified": 1729527199, |
@@ -21,22 +33,6 @@ | |||
21 | "type": "github" | 33 | "type": "github" |
22 | } | 34 | } |
23 | }, | 35 | }, |
24 | "flake-compat": { | ||
25 | "flake": false, | ||
26 | "locked": { | ||
27 | "lastModified": 1696426674, | ||
28 | "narHash": "sha256-kvjfFW7WAETZlt09AgDn1MrtKzP7t90Vf7vypd3OL1U=", | ||
29 | "owner": "edolstra", | ||
30 | "repo": "flake-compat", | ||
31 | "rev": "0f9255e01c2351cc7d116c072cb317785dd33b33", | ||
32 | "type": "github" | ||
33 | }, | ||
34 | "original": { | ||
35 | "owner": "edolstra", | ||
36 | "repo": "flake-compat", | ||
37 | "type": "github" | ||
38 | } | ||
39 | }, | ||
40 | "flake-utils": { | 36 | "flake-utils": { |
41 | "locked": { | 37 | "locked": { |
42 | "lastModified": 1659877975, | 38 | "lastModified": 1659877975, |
@@ -52,28 +48,6 @@ | |||
52 | "type": "github" | 48 | "type": "github" |
53 | } | 49 | } |
54 | }, | 50 | }, |
55 | "gitignore": { | ||
56 | "inputs": { | ||
57 | "nixpkgs": [ | ||
58 | "hyprland", | ||
59 | "pre-commit-hooks", | ||
60 | "nixpkgs" | ||
61 | ] | ||
62 | }, | ||
63 | "locked": { | ||
64 | "lastModified": 1709087332, | ||
65 | "narHash": "sha256-HG2cCnktfHsKV0s4XW83gU3F57gaTljL9KNSuG6bnQs=", | ||
66 | "owner": "hercules-ci", | ||
67 | "repo": "gitignore.nix", | ||
68 | "rev": "637db329424fd7e46cf4185293b9cc8c88c95394", | ||
69 | "type": "github" | ||
70 | }, | ||
71 | "original": { | ||
72 | "owner": "hercules-ci", | ||
73 | "repo": "gitignore.nix", | ||
74 | "type": "github" | ||
75 | } | ||
76 | }, | ||
77 | "home-manager": { | 51 | "home-manager": { |
78 | "inputs": { | 52 | "inputs": { |
79 | "nixpkgs": [ | 53 | "nixpkgs": [ |
@@ -130,26 +104,25 @@ | |||
130 | "hyprcursor": "hyprcursor", | 104 | "hyprcursor": "hyprcursor", |
131 | "hyprland-protocols": "hyprland-protocols", | 105 | "hyprland-protocols": "hyprland-protocols", |
132 | "hyprlang": "hyprlang", | 106 | "hyprlang": "hyprlang", |
133 | "hyprutils": "hyprutils_2", | 107 | "hyprutils": "hyprutils", |
134 | "hyprwayland-scanner": "hyprwayland-scanner_2", | 108 | "hyprwayland-scanner": "hyprwayland-scanner", |
135 | "nixpkgs": [ | 109 | "nixpkgs": [ |
136 | "nixpkgs" | 110 | "nixpkgs" |
137 | ], | 111 | ], |
138 | "pre-commit-hooks": "pre-commit-hooks", | 112 | "systems": "systems", |
139 | "systems": "systems_2", | ||
140 | "xdph": "xdph" | 113 | "xdph": "xdph" |
141 | }, | 114 | }, |
142 | "locked": { | 115 | "locked": { |
143 | "lastModified": 1729553322, | 116 | "lastModified": 1728478479, |
144 | "narHash": "sha256-CjdhWsojvgZEr2t8eK6HaaWmLxirnaEckeXt/kveQNs=", | 117 | "narHash": "sha256-AbfdIlK92oWpI39xlIaUekPeL9u95sXzxVsSqhIMfIc=", |
145 | "owner": "hyprwm", | 118 | "owner": "hyprwm", |
146 | "repo": "hyprland", | 119 | "repo": "hyprland", |
147 | "rev": "5e96d738e698f22969ca502d042d5751711c6d8a", | 120 | "rev": "4520b30d498daca8079365bdb909a8dea38e8d55", |
148 | "type": "github" | 121 | "type": "github" |
149 | }, | 122 | }, |
150 | "original": { | 123 | "original": { |
151 | "owner": "hyprwm", | 124 | "owner": "hyprwm", |
152 | "ref": "main", | 125 | "ref": "v0.44.1", |
153 | "repo": "hyprland", | 126 | "repo": "hyprland", |
154 | "type": "github" | 127 | "type": "github" |
155 | } | 128 | } |
@@ -179,6 +152,33 @@ | |||
179 | "type": "github" | 152 | "type": "github" |
180 | } | 153 | } |
181 | }, | 154 | }, |
155 | "hyprland-protocols_2": { | ||
156 | "inputs": { | ||
157 | "nixpkgs": [ | ||
158 | "hyprland", | ||
159 | "xdph", | ||
160 | "nixpkgs" | ||
161 | ], | ||
162 | "systems": [ | ||
163 | "hyprland", | ||
164 | "xdph", | ||
165 | "systems" | ||
166 | ] | ||
167 | }, | ||
168 | "locked": { | ||
169 | "lastModified": 1728345020, | ||
170 | "narHash": "sha256-xGbkc7U/Roe0/Cv3iKlzijIaFBNguasI31ynL2IlEoM=", | ||
171 | "owner": "hyprwm", | ||
172 | "repo": "hyprland-protocols", | ||
173 | "rev": "a7c183800e74f337753de186522b9017a07a8cee", | ||
174 | "type": "github" | ||
175 | }, | ||
176 | "original": { | ||
177 | "owner": "hyprwm", | ||
178 | "repo": "hyprland-protocols", | ||
179 | "type": "github" | ||
180 | } | ||
181 | }, | ||
182 | "hyprlang": { | 182 | "hyprlang": { |
183 | "inputs": { | 183 | "inputs": { |
184 | "hyprutils": [ | 184 | "hyprutils": [ |
@@ -210,12 +210,12 @@ | |||
210 | }, | 210 | }, |
211 | "hyprpicker-git": { | 211 | "hyprpicker-git": { |
212 | "inputs": { | 212 | "inputs": { |
213 | "hyprutils": "hyprutils_3", | 213 | "hyprutils": "hyprutils_2", |
214 | "hyprwayland-scanner": "hyprwayland-scanner_3", | 214 | "hyprwayland-scanner": "hyprwayland-scanner_2", |
215 | "nixpkgs": [ | 215 | "nixpkgs": [ |
216 | "nixpkgs" | 216 | "nixpkgs" |
217 | ], | 217 | ], |
218 | "systems": "systems_3" | 218 | "systems": "systems_2" |
219 | }, | 219 | }, |
220 | "locked": { | 220 | "locked": { |
221 | "lastModified": 1727705155, | 221 | "lastModified": 1727705155, |
@@ -236,12 +236,10 @@ | |||
236 | "inputs": { | 236 | "inputs": { |
237 | "nixpkgs": [ | 237 | "nixpkgs": [ |
238 | "hyprland", | 238 | "hyprland", |
239 | "aquamarine", | ||
240 | "nixpkgs" | 239 | "nixpkgs" |
241 | ], | 240 | ], |
242 | "systems": [ | 241 | "systems": [ |
243 | "hyprland", | 242 | "hyprland", |
244 | "aquamarine", | ||
245 | "systems" | 243 | "systems" |
246 | ] | 244 | ] |
247 | }, | 245 | }, |
@@ -262,31 +260,6 @@ | |||
262 | "hyprutils_2": { | 260 | "hyprutils_2": { |
263 | "inputs": { | 261 | "inputs": { |
264 | "nixpkgs": [ | 262 | "nixpkgs": [ |
265 | "hyprland", | ||
266 | "nixpkgs" | ||
267 | ], | ||
268 | "systems": [ | ||
269 | "hyprland", | ||
270 | "systems" | ||
271 | ] | ||
272 | }, | ||
273 | "locked": { | ||
274 | "lastModified": 1728941256, | ||
275 | "narHash": "sha256-WRypmcZ2Bw94lLmcmxYokVOHPJSZ7T06V49QZ4tkZeQ=", | ||
276 | "owner": "hyprwm", | ||
277 | "repo": "hyprutils", | ||
278 | "rev": "fd4be8b9ca932f7384e454bcd923c5451ef2aa85", | ||
279 | "type": "github" | ||
280 | }, | ||
281 | "original": { | ||
282 | "owner": "hyprwm", | ||
283 | "repo": "hyprutils", | ||
284 | "type": "github" | ||
285 | } | ||
286 | }, | ||
287 | "hyprutils_3": { | ||
288 | "inputs": { | ||
289 | "nixpkgs": [ | ||
290 | "hyprpicker-git", | 263 | "hyprpicker-git", |
291 | "nixpkgs" | 264 | "nixpkgs" |
292 | ], | 265 | ], |
@@ -313,12 +286,10 @@ | |||
313 | "inputs": { | 286 | "inputs": { |
314 | "nixpkgs": [ | 287 | "nixpkgs": [ |
315 | "hyprland", | 288 | "hyprland", |
316 | "aquamarine", | ||
317 | "nixpkgs" | 289 | "nixpkgs" |
318 | ], | 290 | ], |
319 | "systems": [ | 291 | "systems": [ |
320 | "hyprland", | 292 | "hyprland", |
321 | "aquamarine", | ||
322 | "systems" | 293 | "systems" |
323 | ] | 294 | ] |
324 | }, | 295 | }, |
@@ -339,11 +310,11 @@ | |||
339 | "hyprwayland-scanner_2": { | 310 | "hyprwayland-scanner_2": { |
340 | "inputs": { | 311 | "inputs": { |
341 | "nixpkgs": [ | 312 | "nixpkgs": [ |
342 | "hyprland", | 313 | "hyprpicker-git", |
343 | "nixpkgs" | 314 | "nixpkgs" |
344 | ], | 315 | ], |
345 | "systems": [ | 316 | "systems": [ |
346 | "hyprland", | 317 | "hyprpicker-git", |
347 | "systems" | 318 | "systems" |
348 | ] | 319 | ] |
349 | }, | 320 | }, |
@@ -361,28 +332,18 @@ | |||
361 | "type": "github" | 332 | "type": "github" |
362 | } | 333 | } |
363 | }, | 334 | }, |
364 | "hyprwayland-scanner_3": { | 335 | "mozff": { |
365 | "inputs": { | ||
366 | "nixpkgs": [ | ||
367 | "hyprpicker-git", | ||
368 | "nixpkgs" | ||
369 | ], | ||
370 | "systems": [ | ||
371 | "hyprpicker-git", | ||
372 | "systems" | ||
373 | ] | ||
374 | }, | ||
375 | "locked": { | 336 | "locked": { |
376 | "lastModified": 1726874836, | 337 | "lastModified": 1704373101, |
377 | "narHash": "sha256-VKR0sf0PSNCB0wPHVKSAn41mCNVCnegWmgkrneKDhHM=", | 338 | "narHash": "sha256-+gi59LRWRQmwROrmE1E2b3mtocwueCQqZ60CwLG+gbg=", |
378 | "owner": "hyprwm", | 339 | "owner": "mozilla", |
379 | "repo": "hyprwayland-scanner", | 340 | "repo": "nixpkgs-mozilla", |
380 | "rev": "500c81a9e1a76760371049a8d99e008ea77aa59e", | 341 | "rev": "9b11a87c0cc54e308fa83aac5b4ee1816d5418a2", |
381 | "type": "github" | 342 | "type": "github" |
382 | }, | 343 | }, |
383 | "original": { | 344 | "original": { |
384 | "owner": "hyprwm", | 345 | "owner": "mozilla", |
385 | "repo": "hyprwayland-scanner", | 346 | "repo": "nixpkgs-mozilla", |
386 | "type": "github" | 347 | "type": "github" |
387 | } | 348 | } |
388 | }, | 349 | }, |
@@ -410,38 +371,6 @@ | |||
410 | }, | 371 | }, |
411 | "nixpkgs": { | 372 | "nixpkgs": { |
412 | "locked": { | 373 | "locked": { |
413 | "lastModified": 1729413321, | ||
414 | "narHash": "sha256-I4tuhRpZFa6Fu6dcH9Dlo5LlH17peT79vx1y1SpeKt0=", | ||
415 | "owner": "NixOS", | ||
416 | "repo": "nixpkgs", | ||
417 | "rev": "1997e4aa514312c1af7e2bda7fad1644e778ff26", | ||
418 | "type": "github" | ||
419 | }, | ||
420 | "original": { | ||
421 | "owner": "NixOS", | ||
422 | "ref": "nixos-unstable", | ||
423 | "repo": "nixpkgs", | ||
424 | "type": "github" | ||
425 | } | ||
426 | }, | ||
427 | "nixpkgs-stable": { | ||
428 | "locked": { | ||
429 | "lastModified": 1720386169, | ||
430 | "narHash": "sha256-NGKVY4PjzwAa4upkGtAMz1npHGoRzWotlSnVlqI40mo=", | ||
431 | "owner": "NixOS", | ||
432 | "repo": "nixpkgs", | ||
433 | "rev": "194846768975b7ad2c4988bdb82572c00222c0d7", | ||
434 | "type": "github" | ||
435 | }, | ||
436 | "original": { | ||
437 | "owner": "NixOS", | ||
438 | "ref": "nixos-24.05", | ||
439 | "repo": "nixpkgs", | ||
440 | "type": "github" | ||
441 | } | ||
442 | }, | ||
443 | "nixpkgs_2": { | ||
444 | "locked": { | ||
445 | "lastModified": 1729168305, | 374 | "lastModified": 1729168305, |
446 | "narHash": "sha256-jmhxZnrlOyLEMUL2+JkVfkN0XWXI5uE6EB5kVZFR0fo=", | 375 | "narHash": "sha256-jmhxZnrlOyLEMUL2+JkVfkN0XWXI5uE6EB5kVZFR0fo=", |
447 | "owner": "nixos", | 376 | "owner": "nixos", |
@@ -456,37 +385,14 @@ | |||
456 | "type": "github" | 385 | "type": "github" |
457 | } | 386 | } |
458 | }, | 387 | }, |
459 | "pre-commit-hooks": { | ||
460 | "inputs": { | ||
461 | "flake-compat": "flake-compat", | ||
462 | "gitignore": "gitignore", | ||
463 | "nixpkgs": [ | ||
464 | "hyprland", | ||
465 | "nixpkgs" | ||
466 | ], | ||
467 | "nixpkgs-stable": "nixpkgs-stable" | ||
468 | }, | ||
469 | "locked": { | ||
470 | "lastModified": 1728778939, | ||
471 | "narHash": "sha256-WybK5E3hpGxtCYtBwpRj1E9JoiVxe+8kX83snTNaFHE=", | ||
472 | "owner": "cachix", | ||
473 | "repo": "git-hooks.nix", | ||
474 | "rev": "ff68f91754be6f3427e4986d7949e6273659be1d", | ||
475 | "type": "github" | ||
476 | }, | ||
477 | "original": { | ||
478 | "owner": "cachix", | ||
479 | "repo": "git-hooks.nix", | ||
480 | "type": "github" | ||
481 | } | ||
482 | }, | ||
483 | "root": { | 388 | "root": { |
484 | "inputs": { | 389 | "inputs": { |
485 | "home-manager": "home-manager", | 390 | "home-manager": "home-manager", |
486 | "hyprland": "hyprland", | 391 | "hyprland": "hyprland", |
487 | "hyprpicker-git": "hyprpicker-git", | 392 | "hyprpicker-git": "hyprpicker-git", |
393 | "mozff": "mozff", | ||
488 | "nixgl": "nixgl", | 394 | "nixgl": "nixgl", |
489 | "nixpkgs": "nixpkgs_2" | 395 | "nixpkgs": "nixpkgs" |
490 | } | 396 | } |
491 | }, | 397 | }, |
492 | "systems": { | 398 | "systems": { |
@@ -519,27 +425,9 @@ | |||
519 | "type": "github" | 425 | "type": "github" |
520 | } | 426 | } |
521 | }, | 427 | }, |
522 | "systems_3": { | ||
523 | "locked": { | ||
524 | "lastModified": 1689347949, | ||
525 | "narHash": "sha256-12tWmuL2zgBgZkdoB6qXZsgJEH9LR3oUgpaQq2RbI80=", | ||
526 | "owner": "nix-systems", | ||
527 | "repo": "default-linux", | ||
528 | "rev": "31732fcf5e8fea42e59c2488ad31a0e651500f68", | ||
529 | "type": "github" | ||
530 | }, | ||
531 | "original": { | ||
532 | "owner": "nix-systems", | ||
533 | "repo": "default-linux", | ||
534 | "type": "github" | ||
535 | } | ||
536 | }, | ||
537 | "xdph": { | 428 | "xdph": { |
538 | "inputs": { | 429 | "inputs": { |
539 | "hyprland-protocols": [ | 430 | "hyprland-protocols": "hyprland-protocols_2", |
540 | "hyprland", | ||
541 | "hyprland-protocols" | ||
542 | ], | ||
543 | "hyprlang": [ | 431 | "hyprlang": [ |
544 | "hyprland", | 432 | "hyprland", |
545 | "hyprlang" | 433 | "hyprlang" |
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix index 419cf50..becb34f 100644 --- a/home-config/nix-home-manager/flake.nix +++ b/home-config/nix-home-manager/flake.nix | |||
@@ -13,23 +13,24 @@ | |||
13 | inputs.nixpkgs.follows = "nixpkgs"; | 13 | inputs.nixpkgs.follows = "nixpkgs"; |
14 | }; | 14 | }; |
15 | hyprland = { | 15 | hyprland = { |
16 | url = "github:hyprwm/hyprland/main"; | 16 | url = "github:hyprwm/hyprland/v0.44.1"; |
17 | inputs.nixpkgs.follows = "nixpkgs"; | 17 | inputs.nixpkgs.follows = "nixpkgs"; |
18 | inputs.aquamarine.url = "github:hyprwm/aquamarine/main"; | ||
19 | }; | 18 | }; |
20 | nixgl = { | 19 | nixgl = { |
21 | url = "github:nix-community/nixGL/310f8e49a149e4c9ea52f1adf70cdc768ec53f8a"; | 20 | url = "github:nix-community/nixGL/310f8e49a149e4c9ea52f1adf70cdc768ec53f8a"; |
22 | inputs.nixpkgs.follows = "nixpkgs"; | 21 | inputs.nixpkgs.follows = "nixpkgs"; |
23 | }; | 22 | }; |
23 | mozff.url = "github:mozilla/nixpkgs-mozilla"; | ||
24 | }; | 24 | }; |
25 | 25 | ||
26 | outputs = { nixpkgs, home-manager, hyprpicker-git, hyprland, nixgl, ... }@inputs: | 26 | outputs = { nixpkgs, home-manager, hyprpicker-git, hyprland, nixgl, mozff, ... }@inputs: |
27 | let | 27 | let |
28 | system = "x86_64-linux"; | 28 | system = "x86_64-linux"; |
29 | pkgs = nixpkgs.legacyPackages.${system}; | 29 | pkgs = nixpkgs.legacyPackages.${system}; |
30 | overlays = [ | 30 | overlays = [ |
31 | hyprpicker-git.overlays.default | 31 | hyprpicker-git.overlays.default |
32 | nixgl.overlay | 32 | nixgl.overlay |
33 | mozff.overlays.firefox | ||
33 | ]; | 34 | ]; |
34 | in { | 35 | in { |
35 | homeConfigurations."ryan" = home-manager.lib.homeManagerConfiguration { | 36 | homeConfigurations."ryan" = home-manager.lib.homeManagerConfiguration { |
@@ -38,8 +39,8 @@ | |||
38 | # Specify your home configuration modules here, for example, | 39 | # Specify your home configuration modules here, for example, |
39 | # the path to your home.nix. | 40 | # the path to your home.nix. |
40 | modules = [ | 41 | modules = [ |
41 | ./home.nix | ||
42 | {nixpkgs.overlays = overlays;} | 42 | {nixpkgs.overlays = overlays;} |
43 | ./home.nix | ||
43 | { | 44 | { |
44 | _module.args = { | 45 | _module.args = { |
45 | inherit hyprland; | 46 | inherit hyprland; |
@@ -50,7 +51,7 @@ | |||
50 | 51 | ||
51 | # Optionally use extraSpecialArgs | 52 | # Optionally use extraSpecialArgs |
52 | # to pass through arguments to home.nix | 53 | # to pass through arguments to home.nix |
53 | #extraSpecialArgs = { inherit inputs; }; | 54 | # extraSpecialArgs = { inherit overlays; }; |
54 | }; | 55 | }; |
55 | }; | 56 | }; |
56 | } | 57 | } |
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix index 031e76a..65afdd3 100644 --- a/home-config/nix-home-manager/home.nix +++ b/home-config/nix-home-manager/home.nix | |||
@@ -58,7 +58,7 @@ | |||
58 | libvdpau | 58 | libvdpau |
59 | wpaperd | 59 | wpaperd |
60 | hypridle | 60 | hypridle |
61 | firefox | 61 | latest.firefox-nightly-bin |
62 | eza | 62 | eza |
63 | 63 | ||
64 | # Wrapped programs for some env variables | 64 | # Wrapped programs for some env variables |