summaryrefslogtreecommitdiff
path: root/home-config/home-configuration.scm
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-10-28 22:55:28 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2024-10-28 22:55:28 -0400
commitc23b60f866a687aa6ae3618265f47ae63c9c5b64 (patch)
treec75d58973f8309cf9e996dfef751bed2608ef777 /home-config/home-configuration.scm
parent1c3f6332247dbd7f27bd89779a93bf39d5297f39 (diff)
wttr popup fix, firefox on nix, fontconfig fixes
Diffstat (limited to 'home-config/home-configuration.scm')
-rw-r--r--home-config/home-configuration.scm24
1 files changed, 22 insertions, 2 deletions
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm
index b9e95d0..683f6aa 100644
--- a/home-config/home-configuration.scm
+++ b/home-config/home-configuration.scm
@@ -15,6 +15,7 @@
15 (gnu home services shells) 15 (gnu home services shells)
16 (gnu home services desktop) 16 (gnu home services desktop)
17 (gnu home services gnupg) 17 (gnu home services gnupg)
18 (gnu home services fontutils)
18 (gnu home services) 19 (gnu home services)
19 (ryan-services pipewire) 20 (ryan-services pipewire)
20 (ryan-services spotify) 21 (ryan-services spotify)
@@ -134,7 +135,7 @@
134 "signal-desktop" 135 "signal-desktop"
135 "sc-im" 136 "sc-im"
136 "git-lfs")) 137 "git-lfs"))
137 (list my-neovim wl-mirror firefox-wrapped calcurse-fixed ))) 138 (list my-neovim wl-mirror calcurse-fixed )))
138 139
139 ;; Below is the list of Home services. To search for available 140 ;; Below is the list of Home services. To search for available
140 ;; services, run 'guix home search KEYWORD' in a terminal. 141 ;; services, run 'guix home search KEYWORD' in a terminal.
@@ -169,12 +170,31 @@
169 (".mozilla/native-messaging-hosts/tridactyl.json" ,(local-file "tridactyl/tridactyl.json")) 170 (".mozilla/native-messaging-hosts/tridactyl.json" ,(local-file "tridactyl/tridactyl.json"))
170 ;(".gnupg/sshcontrol" ,(local-file "gnupg/sshcontrol")) 171 ;(".gnupg/sshcontrol" ,(local-file "gnupg/sshcontrol"))
171 ;(".gnupg/gpg-agent.conf" ,(local-file "gnupg/gpg-agent.conf")) 172 ;(".gnupg/gpg-agent.conf" ,(local-file "gnupg/gpg-agent.conf"))
172 (".fonts" ,(local-file "fonts" #:recursive? #t)) 173 (".local/share/fonts" ,(local-file "fonts" #:recursive? #t))
173 (".gitconfig" ,(local-file "gitconfig")) 174 (".gitconfig" ,(local-file "gitconfig"))
174 (".docker/cli-plugins" ,(local-file "docker/cli-plugins" #:recursive? #t)) 175 (".docker/cli-plugins" ,(local-file "docker/cli-plugins" #:recursive? #t))
175 (".nix-channels" ,(local-file "nix-channels")))) 176 (".nix-channels" ,(local-file "nix-channels"))))
176 (service home-pipewire-service-type) 177 (service home-pipewire-service-type)
177 (service home-spotifyd-service-type) 178 (service home-spotifyd-service-type)
179 ; font things for nix to play nice
180 (simple-service 'additional-fonts-service
181 home-fontconfig-service-type
182 (list "~/.nix-profile/share/fonts"
183 '(match (@ (target "pattern"))
184 (edit (@ (name "family") (mode "prepend"))
185 (string "DejaVu Sans")))
186 '(alias
187 (family "serif")
188 (prefer
189 (family "DejaVu Serif")))
190 '(alias
191 (family "sans")
192 (prefer
193 (family "DejaVu Sans")))
194 '(alias
195 (family "monospace")
196 (prefer
197 (family "DejaVu Sans Mono")))))
178 (service home-dbus-service-type) 198 (service home-dbus-service-type)
179 ;;; trying some changes 199 ;;; trying some changes
180 ;(template-files "." 200 ;(template-files "."