summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/home.nix
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2025-01-20 20:49:03 -0500
committerRyan Schanzenbacher <ryan@rschanz.org>2025-01-20 20:49:03 -0500
commitddd6e973d651b9d9c4d160c8ebb288daa071e259 (patch)
treebe36f38ac02a15468dee4e9ab795975636fee844 /home-config/nix-home-manager/home.nix
parentce1c24e3100d48c9c210eb1ebc5ebadcc6b77659 (diff)
Updated Thinkpad config to latest, updated all packages, updated docker
compose, changed nixGL to make hyprland work again, now using bash with starship config
Diffstat (limited to 'home-config/nix-home-manager/home.nix')
-rw-r--r--home-config/nix-home-manager/home.nix30
1 files changed, 25 insertions, 5 deletions
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index 5e85304..4c889c9 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -15,6 +15,9 @@
15 home.username = "ryan"; 15 home.username = "ryan";
16 home.homeDirectory = "/home/ryan"; 16 home.homeDirectory = "/home/ryan";
17 17
18 # Ignore news
19 news.display = "silent";
20
18 # This value determines the Home Manager release that your configuration is 21 # This value determines the Home Manager release that your configuration is
19 # compatible with. This helps avoid breakage when a new Home Manager release 22 # compatible with. This helps avoid breakage when a new Home Manager release
20 # introduces backwards incompatible changes. 23 # introduces backwards incompatible changes.
@@ -344,6 +347,22 @@
344 }; 347 };
345}; 348};
346 349
350 programs.starship = {
351 enable = true;
352 settings = {
353 add_newline = false;
354 character = {
355 success_symbol = "[➜](bold green)";
356 error_symbol = "[➜](bold red)";
357 };
358 time = {
359 disabled = false;
360 format = "\[ $time \]($style)";
361 time_format = "%T";
362 };
363 };
364 };
365
347 # The home.packages option allows you to install Nix packages into your 366 # The home.packages option allows you to install Nix packages into your
348 # environment. 367 # environment.
349 home.packages = with pkgs; [ 368 home.packages = with pkgs; [
@@ -377,13 +396,14 @@
377 #latest.firefox-nightly-bin 396 #latest.firefox-nightly-bin
378 eza 397 eza
379 wl-mirror 398 wl-mirror
399 starship
380 400
381 # Wrapped programs for some env variables 401 # Wrapped programs for some env variables
382 (pkgs.writeScriptBin "hyprlock" '' 402 # (pkgs.writeScriptBin "hyprlock" ''
383 #! ${pkgs.bash}/bin/bash 403 # #! ${pkgs.bash}/bin/bash
384 export LD_PRELOAD="/run/current-system/profile/lib/libpam.so.0:/run/current-system/profile/lib/libfontconfig.so:$LD_PRELOAD" 404 # export LD_PRELOAD="/run/current-system/profile/lib/libpam.so.0:/run/current-system/profile/lib/libfontconfig.so:$LD_PRELOAD"
385 exec ${pkgs.hyprlock}/bin/hyprlock "$@" 405 # exec ${pkgs.hyprlock}/bin/hyprlock "$@"
386 '') 406 # '')
387 407
388 # Flakes specific things defined in flake.nix 408 # Flakes specific things defined in flake.nix
389 hyprland.packages.${pkgs.system}.default 409 hyprland.packages.${pkgs.system}.default