summaryrefslogtreecommitdiff
path: root/home-config/fish/functions/tide/configure/configs/lean.fish
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/fish/functions/tide/configure/configs/lean.fish')
-rw-r--r--home-config/fish/functions/tide/configure/configs/lean.fish116
1 files changed, 116 insertions, 0 deletions
diff --git a/home-config/fish/functions/tide/configure/configs/lean.fish b/home-config/fish/functions/tide/configure/configs/lean.fish
new file mode 100644
index 0000000..a958a17
--- /dev/null
+++ b/home-config/fish/functions/tide/configure/configs/lean.fish
@@ -0,0 +1,116 @@
1tide_aws_bg_color normal
2tide_aws_color FF9900
3tide_character_color $_tide_color_green
4tide_character_color_failure FF0000
5tide_cmd_duration_bg_color normal
6tide_cmd_duration_color 87875F
7tide_cmd_duration_decimals 0
8tide_cmd_duration_threshold 3000
9tide_context_always_display false
10tide_context_bg_color normal
11tide_context_color_default D7AF87
12tide_context_color_root $_tide_color_gold
13tide_context_color_ssh D7AF87
14tide_context_hostname_parts 1
15tide_crystal_bg_color normal
16tide_crystal_color FFFFFF
17tide_direnv_bg_color normal
18tide_direnv_bg_color_denied normal
19tide_direnv_color $_tide_color_gold
20tide_direnv_color_denied FF0000
21tide_distrobox_bg_color normal
22tide_distrobox_color FF00FF
23tide_docker_bg_color normal
24tide_docker_color 2496ED
25tide_docker_default_contexts default colima
26tide_elixir_bg_color normal
27tide_elixir_color 4E2A8E
28tide_gcloud_bg_color normal
29tide_gcloud_color 4285F4
30tide_git_bg_color normal
31tide_git_bg_color_unstable normal
32tide_git_bg_color_urgent normal
33tide_git_color_branch $_tide_color_green
34tide_git_color_conflicted FF0000
35tide_git_color_dirty $_tide_color_gold
36tide_git_color_operation FF0000
37tide_git_color_staged $_tide_color_gold
38tide_git_color_stash $_tide_color_green
39tide_git_color_untracked $_tide_color_light_blue
40tide_git_color_upstream $_tide_color_green
41tide_git_truncation_length 24
42tide_git_truncation_strategy
43tide_go_bg_color normal
44tide_go_color 00ACD7
45tide_java_bg_color normal
46tide_java_color ED8B00
47tide_jobs_bg_color normal
48tide_jobs_color $_tide_color_dark_green
49tide_jobs_number_threshold 1000
50tide_kubectl_bg_color normal
51tide_kubectl_color 326CE5
52tide_left_prompt_frame_enabled false
53tide_left_prompt_items pwd git newline character
54tide_left_prompt_prefix ''
55tide_left_prompt_separator_diff_color ' '
56tide_left_prompt_separator_same_color ' '
57tide_left_prompt_suffix ' '
58tide_nix_shell_bg_color normal
59tide_nix_shell_color 7EBAE4
60tide_node_bg_color normal
61tide_node_color 44883E
62tide_os_bg_color normal
63tide_os_color normal
64tide_php_bg_color normal
65tide_php_color 617CBE
66tide_private_mode_bg_color normal
67tide_private_mode_color FFFFFF
68tide_prompt_add_newline_before true
69tide_prompt_color_frame_and_connection 6C6C6C
70tide_prompt_color_separator_same_color 949494
71tide_prompt_min_cols 34
72tide_prompt_pad_items false
73tide_prompt_transient_enabled false
74tide_pulumi_bg_color normal
75tide_pulumi_color F7BF2A
76tide_pwd_bg_color normal
77tide_pwd_color_anchors $_tide_color_light_blue
78tide_pwd_color_dirs $_tide_color_dark_blue
79tide_pwd_color_truncated_dirs 8787AF
80tide_pwd_markers .bzr .citc .git .hg .node-version .python-version .ruby-version .shorten_folder_marker .svn .terraform Cargo.toml composer.json CVS go.mod package.json build.zig
81tide_python_bg_color normal
82tide_python_color 00AFAF
83tide_right_prompt_frame_enabled false
84tide_right_prompt_items status cmd_duration context jobs direnv node python rustc java php pulumi ruby go gcloud kubectl distrobox toolbox terraform aws nix_shell crystal elixir zig
85tide_right_prompt_prefix ' '
86tide_right_prompt_separator_diff_color ' '
87tide_right_prompt_separator_same_color ' '
88tide_right_prompt_suffix ''
89tide_ruby_bg_color normal
90tide_ruby_color B31209
91tide_rustc_bg_color normal
92tide_rustc_color F74C00
93tide_shlvl_bg_color normal
94tide_shlvl_color d78700
95tide_shlvl_threshold 1
96tide_status_bg_color normal
97tide_status_bg_color_failure normal
98tide_status_color $_tide_color_dark_green
99tide_status_color_failure D70000
100tide_terraform_bg_color normal
101tide_terraform_color 844FBA
102tide_time_bg_color normal
103tide_time_color 5F8787
104tide_time_format %T
105tide_toolbox_bg_color normal
106tide_toolbox_color 613583
107tide_vi_mode_bg_color_default normal
108tide_vi_mode_bg_color_insert normal
109tide_vi_mode_bg_color_replace normal
110tide_vi_mode_bg_color_visual normal
111tide_vi_mode_color_default 949494
112tide_vi_mode_color_insert 87AFAF
113tide_vi_mode_color_replace 87AF87
114tide_vi_mode_color_visual FF8700
115tide_zig_bg_color normal
116tide_zig_color F7A41D