summaryrefslogtreecommitdiff
path: root/home-config/fish/functions/tide/configure/configs
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/fish/functions/tide/configure/configs')
-rw-r--r--home-config/fish/functions/tide/configure/configs/classic.fish116
-rw-r--r--home-config/fish/functions/tide/configure/configs/classic_16color.fish89
-rw-r--r--home-config/fish/functions/tide/configure/configs/lean.fish116
-rw-r--r--home-config/fish/functions/tide/configure/configs/lean_16color.fish89
-rw-r--r--home-config/fish/functions/tide/configure/configs/rainbow.fish116
-rw-r--r--home-config/fish/functions/tide/configure/configs/rainbow_16color.fish93
6 files changed, 619 insertions, 0 deletions
diff --git a/home-config/fish/functions/tide/configure/configs/classic.fish b/home-config/fish/functions/tide/configure/configs/classic.fish
new file mode 100644
index 0000000..8973cbc
--- /dev/null
+++ b/home-config/fish/functions/tide/configure/configs/classic.fish
@@ -0,0 +1,116 @@
1tide_aws_bg_color 444444
2tide_aws_color FF9900
3tide_character_color $_tide_color_green
4tide_character_color_failure FF0000
5tide_cmd_duration_bg_color 444444
6tide_cmd_duration_color 87875F
7tide_cmd_duration_decimals 0
8tide_cmd_duration_threshold 3000
9tide_context_always_display false
10tide_context_bg_color 444444
11tide_context_color_default D7AF87
12tide_context_color_root $_tide_color_gold
13tide_context_color_ssh D7AF87
14tide_context_hostname_parts 1
15tide_crystal_bg_color 444444
16tide_crystal_color FFFFFF
17tide_direnv_bg_color 444444
18tide_direnv_bg_color_denied 444444
19tide_direnv_color $_tide_color_gold
20tide_direnv_color_denied FF0000
21tide_distrobox_bg_color 444444
22tide_distrobox_color FF00FF
23tide_docker_bg_color 444444
24tide_docker_color 2496ED
25tide_docker_default_contexts default colima
26tide_elixir_bg_color 444444
27tide_elixir_color 4E2A8E
28tide_gcloud_bg_color 444444
29tide_gcloud_color 4285F4
30tide_git_bg_color 444444
31tide_git_bg_color_unstable 444444
32tide_git_bg_color_urgent 444444
33tide_git_color_branch $_tide_color_green
34tide_git_color_conflicted FF0000
35tide_git_color_dirty $_tide_color_gold
36tide_git_color_operation FF0000
37tide_git_color_staged $_tide_color_gold
38tide_git_color_stash $_tide_color_green
39tide_git_color_untracked $_tide_color_light_blue
40tide_git_color_upstream $_tide_color_green
41tide_git_truncation_length 24
42tide_git_truncation_strategy
43tide_go_bg_color 444444
44tide_go_color 00ACD7
45tide_java_bg_color 444444
46tide_java_color ED8B00
47tide_jobs_bg_color 444444
48tide_jobs_color $_tide_color_dark_green
49tide_jobs_number_threshold 1000
50tide_kubectl_bg_color 444444
51tide_kubectl_color 326CE5
52tide_left_prompt_frame_enabled true
53tide_left_prompt_items pwd git newline
54tide_left_prompt_prefix ''
55tide_left_prompt_separator_diff_color 
56tide_left_prompt_separator_same_color 
57tide_left_prompt_suffix 
58tide_nix_shell_bg_color 444444
59tide_nix_shell_color 7EBAE4
60tide_node_bg_color 444444
61tide_node_color 44883E
62tide_os_bg_color 444444
63tide_os_color EEEEEE
64tide_php_bg_color 444444
65tide_php_color 617CBE
66tide_private_mode_bg_color 444444
67tide_private_mode_color FFFFFF
68tide_prompt_add_newline_before true
69tide_prompt_color_frame_and_connection 6C6C6C
70tide_prompt_color_separator_same_color 949494
71tide_prompt_min_cols 34
72tide_prompt_pad_items true
73tide_prompt_transient_enabled false
74tide_pulumi_bg_color 444444
75tide_pulumi_color F7BF2A
76tide_pwd_bg_color 444444
77tide_pwd_color_anchors $_tide_color_light_blue
78tide_pwd_color_dirs $_tide_color_dark_blue
79tide_pwd_color_truncated_dirs 8787AF
80tide_pwd_markers .bzr .citc .git .hg .node-version .python-version .ruby-version .shorten_folder_marker .svn .terraform Cargo.toml composer.json CVS go.mod package.json build.zig
81tide_python_bg_color 444444
82tide_python_color 00AFAF
83tide_right_prompt_frame_enabled true
84tide_right_prompt_items status cmd_duration context jobs direnv node python rustc java php pulumi ruby go gcloud kubectl distrobox toolbox terraform aws nix_shell crystal elixir zig
85tide_right_prompt_prefix 
86tide_right_prompt_separator_diff_color 
87tide_right_prompt_separator_same_color 
88tide_right_prompt_suffix ''
89tide_ruby_bg_color 444444
90tide_ruby_color B31209
91tide_rustc_bg_color 444444
92tide_rustc_color F74C00
93tide_shlvl_bg_color 444444
94tide_shlvl_color d78700
95tide_shlvl_threshold 1
96tide_status_bg_color 444444
97tide_status_bg_color_failure 444444
98tide_status_color $_tide_color_dark_green
99tide_status_color_failure D70000
100tide_terraform_bg_color 444444
101tide_terraform_color 844FBA
102tide_time_bg_color 444444
103tide_time_color 5F8787
104tide_time_format %T
105tide_toolbox_bg_color 444444
106tide_toolbox_color 613583
107tide_vi_mode_bg_color_default 444444
108tide_vi_mode_bg_color_insert 444444
109tide_vi_mode_bg_color_replace 444444
110tide_vi_mode_bg_color_visual 444444
111tide_vi_mode_color_default 949494
112tide_vi_mode_color_insert 87AFAF
113tide_vi_mode_color_replace 87AF87
114tide_vi_mode_color_visual FF8700
115tide_zig_bg_color 444444
116tide_zig_color F7A41D
diff --git a/home-config/fish/functions/tide/configure/configs/classic_16color.fish b/home-config/fish/functions/tide/configure/configs/classic_16color.fish
new file mode 100644
index 0000000..670170f
--- /dev/null
+++ b/home-config/fish/functions/tide/configure/configs/classic_16color.fish
@@ -0,0 +1,89 @@
1tide_aws_bg_color black
2tide_aws_color yellow
3tide_character_color brgreen
4tide_character_color_failure brred
5tide_cmd_duration_bg_color black
6tide_cmd_duration_color brblack
7tide_context_bg_color black
8tide_context_color_default yellow
9tide_context_color_root bryellow
10tide_context_color_ssh yellow
11tide_crystal_bg_color black
12tide_crystal_color brwhite
13tide_direnv_bg_color black
14tide_direnv_bg_color_denied black
15tide_direnv_color bryellow
16tide_direnv_color_denied brred
17tide_distrobox_bg_color black
18tide_distrobox_color brmagenta
19tide_docker_bg_color black
20tide_docker_color blue
21tide_elixir_bg_color black
22tide_elixir_color magenta
23tide_gcloud_bg_color black
24tide_gcloud_color blue
25tide_git_bg_color black
26tide_git_bg_color_unstable black
27tide_git_bg_color_urgent black
28tide_git_color_branch brgreen
29tide_git_color_conflicted brred
30tide_git_color_dirty bryellow
31tide_git_color_operation brred
32tide_git_color_staged bryellow
33tide_git_color_stash brgreen
34tide_git_color_untracked brblue
35tide_git_color_upstream brgreen
36tide_go_bg_color black
37tide_go_color brcyan
38tide_java_bg_color black
39tide_java_color yellow
40tide_jobs_bg_color black
41tide_jobs_color green
42tide_kubectl_bg_color black
43tide_kubectl_color blue
44tide_nix_shell_bg_color black
45tide_nix_shell_color brblue
46tide_node_bg_color black
47tide_node_color green
48tide_os_bg_color black
49tide_os_color brwhite
50tide_php_bg_color black
51tide_php_color blue
52tide_private_mode_bg_color black
53tide_private_mode_color brwhite
54tide_prompt_color_frame_and_connection brblack
55tide_prompt_color_separator_same_color brblack
56tide_pulumi_bg_color black
57tide_pulumi_color yellow
58tide_pwd_bg_color black
59tide_pwd_color_anchors brcyan
60tide_pwd_color_dirs cyan
61tide_pwd_color_truncated_dirs magenta
62tide_python_bg_color black
63tide_python_color cyan
64tide_ruby_bg_color black
65tide_ruby_color red
66tide_rustc_bg_color black
67tide_rustc_color red
68tide_shlvl_bg_color black
69tide_shlvl_color yellow
70tide_status_bg_color black
71tide_status_bg_color_failure black
72tide_status_color green
73tide_status_color_failure red
74tide_terraform_bg_color black
75tide_terraform_color magenta
76tide_time_bg_color black
77tide_time_color brblack
78tide_toolbox_bg_color black
79tide_toolbox_color magenta
80tide_vi_mode_bg_color_default black
81tide_vi_mode_bg_color_insert black
82tide_vi_mode_bg_color_replace black
83tide_vi_mode_bg_color_visual black
84tide_vi_mode_color_default white
85tide_vi_mode_color_insert cyan
86tide_vi_mode_color_replace green
87tide_vi_mode_color_visual yellow
88tide_zig_bg_color black
89tide_zig_color yellow
diff --git a/home-config/fish/functions/tide/configure/configs/lean.fish b/home-config/fish/functions/tide/configure/configs/lean.fish
new file mode 100644
index 0000000..a958a17
--- /dev/null
+++ b/home-config/fish/functions/tide/configure/configs/lean.fish
@@ -0,0 +1,116 @@
1tide_aws_bg_color normal
2tide_aws_color FF9900
3tide_character_color $_tide_color_green
4tide_character_color_failure FF0000
5tide_cmd_duration_bg_color normal
6tide_cmd_duration_color 87875F
7tide_cmd_duration_decimals 0
8tide_cmd_duration_threshold 3000
9tide_context_always_display false
10tide_context_bg_color normal
11tide_context_color_default D7AF87
12tide_context_color_root $_tide_color_gold
13tide_context_color_ssh D7AF87
14tide_context_hostname_parts 1
15tide_crystal_bg_color normal
16tide_crystal_color FFFFFF
17tide_direnv_bg_color normal
18tide_direnv_bg_color_denied normal
19tide_direnv_color $_tide_color_gold
20tide_direnv_color_denied FF0000
21tide_distrobox_bg_color normal
22tide_distrobox_color FF00FF
23tide_docker_bg_color normal
24tide_docker_color 2496ED
25tide_docker_default_contexts default colima
26tide_elixir_bg_color normal
27tide_elixir_color 4E2A8E
28tide_gcloud_bg_color normal
29tide_gcloud_color 4285F4
30tide_git_bg_color normal
31tide_git_bg_color_unstable normal
32tide_git_bg_color_urgent normal
33tide_git_color_branch $_tide_color_green
34tide_git_color_conflicted FF0000
35tide_git_color_dirty $_tide_color_gold
36tide_git_color_operation FF0000
37tide_git_color_staged $_tide_color_gold
38tide_git_color_stash $_tide_color_green
39tide_git_color_untracked $_tide_color_light_blue
40tide_git_color_upstream $_tide_color_green
41tide_git_truncation_length 24
42tide_git_truncation_strategy
43tide_go_bg_color normal
44tide_go_color 00ACD7
45tide_java_bg_color normal
46tide_java_color ED8B00
47tide_jobs_bg_color normal
48tide_jobs_color $_tide_color_dark_green
49tide_jobs_number_threshold 1000
50tide_kubectl_bg_color normal
51tide_kubectl_color 326CE5
52tide_left_prompt_frame_enabled false
53tide_left_prompt_items pwd git newline character
54tide_left_prompt_prefix ''
55tide_left_prompt_separator_diff_color ' '
56tide_left_prompt_separator_same_color ' '
57tide_left_prompt_suffix ' '
58tide_nix_shell_bg_color normal
59tide_nix_shell_color 7EBAE4
60tide_node_bg_color normal
61tide_node_color 44883E
62tide_os_bg_color normal
63tide_os_color normal
64tide_php_bg_color normal
65tide_php_color 617CBE
66tide_private_mode_bg_color normal
67tide_private_mode_color FFFFFF
68tide_prompt_add_newline_before true
69tide_prompt_color_frame_and_connection 6C6C6C
70tide_prompt_color_separator_same_color 949494
71tide_prompt_min_cols 34
72tide_prompt_pad_items false
73tide_prompt_transient_enabled false
74tide_pulumi_bg_color normal
75tide_pulumi_color F7BF2A
76tide_pwd_bg_color normal
77tide_pwd_color_anchors $_tide_color_light_blue
78tide_pwd_color_dirs $_tide_color_dark_blue
79tide_pwd_color_truncated_dirs 8787AF
80tide_pwd_markers .bzr .citc .git .hg .node-version .python-version .ruby-version .shorten_folder_marker .svn .terraform Cargo.toml composer.json CVS go.mod package.json build.zig
81tide_python_bg_color normal
82tide_python_color 00AFAF
83tide_right_prompt_frame_enabled false
84tide_right_prompt_items status cmd_duration context jobs direnv node python rustc java php pulumi ruby go gcloud kubectl distrobox toolbox terraform aws nix_shell crystal elixir zig
85tide_right_prompt_prefix ' '
86tide_right_prompt_separator_diff_color ' '
87tide_right_prompt_separator_same_color ' '
88tide_right_prompt_suffix ''
89tide_ruby_bg_color normal
90tide_ruby_color B31209
91tide_rustc_bg_color normal
92tide_rustc_color F74C00
93tide_shlvl_bg_color normal
94tide_shlvl_color d78700
95tide_shlvl_threshold 1
96tide_status_bg_color normal
97tide_status_bg_color_failure normal
98tide_status_color $_tide_color_dark_green
99tide_status_color_failure D70000
100tide_terraform_bg_color normal
101tide_terraform_color 844FBA
102tide_time_bg_color normal
103tide_time_color 5F8787
104tide_time_format %T
105tide_toolbox_bg_color normal
106tide_toolbox_color 613583
107tide_vi_mode_bg_color_default normal
108tide_vi_mode_bg_color_insert normal
109tide_vi_mode_bg_color_replace normal
110tide_vi_mode_bg_color_visual normal
111tide_vi_mode_color_default 949494
112tide_vi_mode_color_insert 87AFAF
113tide_vi_mode_color_replace 87AF87
114tide_vi_mode_color_visual FF8700
115tide_zig_bg_color normal
116tide_zig_color F7A41D
diff --git a/home-config/fish/functions/tide/configure/configs/lean_16color.fish b/home-config/fish/functions/tide/configure/configs/lean_16color.fish
new file mode 100644
index 0000000..16c2511
--- /dev/null
+++ b/home-config/fish/functions/tide/configure/configs/lean_16color.fish
@@ -0,0 +1,89 @@
1tide_aws_bg_color normal
2tide_aws_color yellow
3tide_character_color brgreen
4tide_character_color_failure brred
5tide_cmd_duration_bg_color normal
6tide_cmd_duration_color brblack
7tide_context_bg_color normal
8tide_context_color_default yellow
9tide_context_color_root bryellow
10tide_context_color_ssh yellow
11tide_crystal_bg_color normal
12tide_crystal_color brwhite
13tide_direnv_bg_color normal
14tide_direnv_bg_color_denied normal
15tide_direnv_color bryellow
16tide_direnv_color_denied brred
17tide_distrobox_bg_color normal
18tide_distrobox_color brmagenta
19tide_docker_bg_color normal
20tide_docker_color blue
21tide_elixir_bg_color normal
22tide_elixir_color magenta
23tide_gcloud_bg_color normal
24tide_gcloud_color blue
25tide_git_bg_color normal
26tide_git_bg_color_unstable normal
27tide_git_bg_color_urgent normal
28tide_git_color_branch brgreen
29tide_git_color_conflicted brred
30tide_git_color_dirty bryellow
31tide_git_color_operation brred
32tide_git_color_staged bryellow
33tide_git_color_stash brgreen
34tide_git_color_untracked brblue
35tide_git_color_upstream brgreen
36tide_go_bg_color normal
37tide_go_color brcyan
38tide_java_bg_color normal
39tide_java_color yellow
40tide_jobs_bg_color normal
41tide_jobs_color green
42tide_kubectl_bg_color normal
43tide_kubectl_color blue
44tide_nix_shell_bg_color normal
45tide_nix_shell_color brblue
46tide_node_bg_color normal
47tide_node_color green
48tide_os_bg_color normal
49tide_os_color brwhite
50tide_php_bg_color normal
51tide_php_color blue
52tide_private_mode_bg_color normal
53tide_private_mode_color brwhite
54tide_prompt_color_frame_and_connection brblack
55tide_prompt_color_separator_same_color brblack
56tide_pulumi_bg_color normal
57tide_pulumi_color yellow
58tide_pwd_bg_color normal
59tide_pwd_color_anchors brcyan
60tide_pwd_color_dirs cyan
61tide_pwd_color_truncated_dirs magenta
62tide_python_bg_color normal
63tide_python_color cyan
64tide_ruby_bg_color normal
65tide_ruby_color red
66tide_rustc_bg_color normal
67tide_rustc_color red
68tide_shlvl_bg_color normal
69tide_shlvl_color yellow
70tide_status_bg_color normal
71tide_status_bg_color_failure normal
72tide_status_color green
73tide_status_color_failure red
74tide_terraform_bg_color normal
75tide_terraform_color magenta
76tide_time_bg_color normal
77tide_time_color brblack
78tide_toolbox_bg_color normal
79tide_toolbox_color magenta
80tide_vi_mode_bg_color_default normal
81tide_vi_mode_bg_color_insert normal
82tide_vi_mode_bg_color_replace normal
83tide_vi_mode_bg_color_visual normal
84tide_vi_mode_color_default white
85tide_vi_mode_color_insert cyan
86tide_vi_mode_color_replace green
87tide_vi_mode_color_visual yellow
88tide_zig_bg_color normal
89tide_zig_color yellow
diff --git a/home-config/fish/functions/tide/configure/configs/rainbow.fish b/home-config/fish/functions/tide/configure/configs/rainbow.fish
new file mode 100644
index 0000000..60c1592
--- /dev/null
+++ b/home-config/fish/functions/tide/configure/configs/rainbow.fish
@@ -0,0 +1,116 @@
1tide_aws_bg_color FF9900
2tide_aws_color 232F3E
3tide_character_color $_tide_color_green
4tide_character_color_failure FF0000
5tide_cmd_duration_bg_color C4A000
6tide_cmd_duration_color 000000
7tide_cmd_duration_decimals 0
8tide_cmd_duration_threshold 3000
9tide_context_always_display false
10tide_context_bg_color 444444
11tide_context_color_default D7AF87
12tide_context_color_root $_tide_color_gold
13tide_context_color_ssh D7AF87
14tide_context_hostname_parts 1
15tide_crystal_bg_color FFFFFF
16tide_crystal_color 000000
17tide_direnv_bg_color $_tide_color_gold
18tide_direnv_bg_color_denied FF0000
19tide_direnv_color 000000
20tide_direnv_color_denied 000000
21tide_distrobox_bg_color FF00FF
22tide_distrobox_color 000000
23tide_docker_bg_color 2496ED
24tide_docker_color 000000
25tide_docker_default_contexts default colima
26tide_elixir_bg_color 4E2A8E
27tide_elixir_color 000000
28tide_gcloud_bg_color 4285F4
29tide_gcloud_color 000000
30tide_git_bg_color 4E9A06
31tide_git_bg_color_unstable C4A000
32tide_git_bg_color_urgent CC0000
33tide_git_color_branch 000000
34tide_git_color_conflicted 000000
35tide_git_color_dirty 000000
36tide_git_color_operation 000000
37tide_git_color_staged 000000
38tide_git_color_stash 000000
39tide_git_color_untracked 000000
40tide_git_color_upstream 000000
41tide_git_truncation_length 24
42tide_git_truncation_strategy
43tide_go_bg_color 00ACD7
44tide_go_color 000000
45tide_java_bg_color ED8B00
46tide_java_color 000000
47tide_jobs_bg_color 444444
48tide_jobs_color 4E9A06
49tide_jobs_number_threshold 1000
50tide_kubectl_bg_color 326CE5
51tide_kubectl_color 000000
52tide_left_prompt_frame_enabled true
53tide_left_prompt_items pwd git newline
54tide_left_prompt_prefix ''
55tide_left_prompt_separator_diff_color 
56tide_left_prompt_separator_same_color 
57tide_left_prompt_suffix 
58tide_nix_shell_bg_color 7EBAE4
59tide_nix_shell_color 000000
60tide_node_bg_color 44883E
61tide_node_color 000000
62tide_os_bg_color $os_branding_bg_color
63tide_os_color $os_branding_color
64tide_php_bg_color 617CBE
65tide_php_color 000000
66tide_private_mode_bg_color F1F3F4
67tide_private_mode_color 000000
68tide_prompt_add_newline_before true
69tide_prompt_color_frame_and_connection 6C6C6C
70tide_prompt_color_separator_same_color 949494
71tide_prompt_min_cols 34
72tide_prompt_pad_items true
73tide_prompt_transient_enabled false
74tide_pulumi_bg_color F7BF2A
75tide_pulumi_color 000000
76tide_pwd_bg_color 3465A4
77tide_pwd_color_anchors E4E4E4
78tide_pwd_color_dirs E4E4E4
79tide_pwd_color_truncated_dirs BCBCBC
80tide_pwd_markers .bzr .citc .git .hg .node-version .python-version .ruby-version .shorten_folder_marker .svn .terraform Cargo.toml composer.json CVS go.mod package.json build.zig
81tide_python_bg_color 444444
82tide_python_color 00AFAF
83tide_right_prompt_frame_enabled true
84tide_right_prompt_items status cmd_duration context jobs direnv node python rustc java php pulumi ruby go gcloud kubectl distrobox toolbox terraform aws nix_shell crystal elixir zig
85tide_right_prompt_prefix 
86tide_right_prompt_separator_diff_color 
87tide_right_prompt_separator_same_color 
88tide_right_prompt_suffix ''
89tide_ruby_bg_color B31209
90tide_ruby_color 000000
91tide_rustc_bg_color F74C00
92tide_rustc_color 000000
93tide_shlvl_bg_color 808000
94tide_shlvl_color 000000
95tide_shlvl_threshold 1
96tide_status_bg_color 2E3436
97tide_status_bg_color_failure CC0000
98tide_status_color 4E9A06
99tide_status_color_failure FFFF00
100tide_terraform_bg_color 800080
101tide_terraform_color 000000
102tide_time_bg_color D3D7CF
103tide_time_color 000000
104tide_time_format %T
105tide_toolbox_bg_color 613583
106tide_toolbox_color 000000
107tide_vi_mode_bg_color_default 949494
108tide_vi_mode_bg_color_insert 87AFAF
109tide_vi_mode_bg_color_replace 87AF87
110tide_vi_mode_bg_color_visual FF8700
111tide_vi_mode_color_default 000000
112tide_vi_mode_color_insert 000000
113tide_vi_mode_color_replace 000000
114tide_vi_mode_color_visual 000000
115tide_zig_bg_color F7A41D
116tide_zig_color 000000
diff --git a/home-config/fish/functions/tide/configure/configs/rainbow_16color.fish b/home-config/fish/functions/tide/configure/configs/rainbow_16color.fish
new file mode 100644
index 0000000..a040f58
--- /dev/null
+++ b/home-config/fish/functions/tide/configure/configs/rainbow_16color.fish
@@ -0,0 +1,93 @@
1tide_aws_bg_color yellow
2tide_aws_color brblack
3tide_character_color brgreen
4tide_character_color_failure brred
5tide_cmd_duration_bg_color yellow
6tide_cmd_duration_color black
7tide_context_bg_color brblack
8tide_context_color_default yellow
9tide_context_color_root yellow
10tide_context_color_ssh yellow
11tide_crystal_bg_color brwhite
12tide_crystal_color black
13tide_direnv_bg_color bryellow
14tide_direnv_bg_color_denied brred
15tide_direnv_color black
16tide_direnv_color_denied black
17tide_distrobox_bg_color brmagenta
18tide_distrobox_color black
19tide_docker_bg_color blue
20tide_docker_color black
21tide_elixir_bg_color magenta
22tide_elixir_color black
23tide_gcloud_bg_color blue
24tide_gcloud_color black
25tide_git_bg_color green
26tide_git_bg_color_unstable yellow
27tide_git_bg_color_urgent red
28tide_git_color_branch black
29tide_git_color_conflicted black
30tide_git_color_dirty black
31tide_git_color_operation black
32tide_git_color_staged black
33tide_git_color_stash black
34tide_git_color_untracked black
35tide_git_color_upstream black
36tide_go_bg_color brcyan
37tide_go_color black
38tide_java_bg_color yellow
39tide_java_color black
40tide_jobs_bg_color brblack
41tide_jobs_color green
42tide_kubectl_bg_color blue
43tide_kubectl_color black
44tide_nix_shell_bg_color brblue
45tide_nix_shell_color black
46tide_node_bg_color green
47tide_node_color black
48tide_os_bg_color white
49tide_os_color black
50tide_php_bg_color blue
51tide_php_color black
52tide_private_mode_bg_color brwhite
53tide_private_mode_color black
54tide_prompt_color_frame_and_connection brblack
55tide_prompt_color_separator_same_color brblack
56tide_pulumi_bg_color yellow
57tide_pulumi_color black
58tide_pwd_bg_color blue
59tide_pwd_color_anchors brwhite
60tide_pwd_color_dirs brwhite
61tide_pwd_color_truncated_dirs white
62tide_python_bg_color brblack
63tide_python_color cyan
64tide_ruby_bg_color red
65tide_ruby_color black
66tide_rustc_bg_color red
67tide_rustc_color black
68tide_shlvl_bg_color yellow
69tide_shlvl_color black
70tide_status_bg_color black
71tide_status_bg_color_failure red
72tide_status_color green
73tide_status_color_failure bryellow
74tide_terraform_bg_color magenta
75tide_terraform_color black
76tide_time_bg_color white
77tide_time_color black
78tide_toolbox_bg_color magenta
79tide_toolbox_color black
80tide_vi_mode_bg_color_default white
81tide_vi_mode_bg_color_insert cyan
82tide_vi_mode_bg_color_replace green
83tide_vi_mode_bg_color_visual yellow
84tide_vi_mode_color_default black
85tide_vi_mode_color_insert black
86tide_vi_mode_color_replace black
87tide_vi_mode_color_visual black
88tide_vi_mode_icon_default D
89tide_vi_mode_icon_insert I
90tide_vi_mode_icon_replace R
91tide_vi_mode_icon_visual V
92tide_zig_bg_color yellow
93tide_zig_color black